Network Inventory - Getting Started _@)

i

This tutorial is a starting point for everyone, who would like to see how to make software and hardware audit of remote
computers with the Network Inventory. If you are making first steps with the application, this tutorial will help you to
quickly familiarize with the user interface and main features.
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Introduction

Any company and organization needs to have hardware and software inventory information in order to plan upgrades
or hardware/software purchases. This information gives you an overview how many and what exact hardware and
software assets do you have and helps to identify what assets you need to add or replace.
Today every PC has tens applications installed and consists of dozen components, including CPU, memory,
motherboard, hard drive, etc. Manual collecting inventory information from one PC can take up to ten minutes. How
long does it take to make inventory of tens, hundreds and thousands PCs in your network? Also consider the fact that
to be useful inventory information should be up-to-date. It's not enough to collect assets information at the purchasing
time, because afterwards configuration can be changed - administrators can replace or remove some hardware, users
can install new applications, etc.
Is there an effective way to make the software and hardware audit? Network Inventory allows automatic collecting
hardware and software assets information from remote PCs and gives you few advantages:

Fast automatic collection of asset information that significantly reduces your time and efforts

Always up-to-date inventory information helps you to make decisions easier

In scope of this tutorial Enterprise Edition will be used. If you would like to follow step-by-step instructions
provided here, please make sure that you downloaded and installed right edition. Otherwise you can notice
different interface options and some missed features.

Application Interface Overview

It's supposed that you successfully downloaded and installed Network Inventory. When you launch it first time, you see
the Trial dialog that asks you to start evaluation or enter a license key. Click on the Evaluate button in order to start 30-
runs evaluation. You will pass on to the main application screen.
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Pic 1. Main application screen

The main application screen is divided on two parts. At the left side you can find Machine Management area that
displays the network tree and asset groups. Management toolbar ENis used to execute main actions, for example,
scan network or update inventory information. The full set of actions is available from the context menu on the tree.
The Machine Tree is located under the management toolbar and contains asset information that can be represented by
two ways. The Networking node Edisplays PCs found in the network, grouped by domains and workgroups. When
some node under the Networking is selected, on the right side you can see related inventory information. For example,
if you select particular PC, you can see its hardware and software assets summary. If you want to learn more about
concrete asset, for example memory on particular PC, you can select Memory Banks under PC's node in the tree and
get detailed information.

Other nodes in the Machine Tree represent particular asset category for all computers in the network. Thus, if you
need to check memory banks information only, you can expand Memory Banks root node in the tree and select
domain/workgroup or particular PC to get information for them.

In order to manage application settings you can switch tabs located under the Machine Tree . Bhe Settings tab
allows you to manage information extracted from remote PCs, so you can enable or skip some parameters. The Alt
Credentials tab is used to set administrative credentials applied to access remote PCs. If your account doesn't have
administrative permissions on remote PCs you need to set administrative account on this tab.

Information displayed on the right side of the main screen depends on the node, selected in the Machine Tree . For
example, if PC node is selected, at the right side you can see Machine Summary information. Management toolbar (D)
is located at the top of the summary and provides a quick access to the most frequent actions, such as report
generation, locking and update functions. Under the toolbar Eyou can find Hardware , Software and Syste m boxes
with the correspondent information about PC.
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Collect Hardware and Software Information from Remote PCs

As you may know, Network Inventory allows you to make hardware and software inventory of remote PCs without
installation of any agents on client computers. It simplifies the process, because in order to prepare to the remote
inventory you just need to check only two things. First, you need to have administrative access to remote PCs. If your
current account doesn't have administrative permissions, you need to go to the Alt Credentials tab and setup
credentials there. Second, you need to switch to the Settings tab and check what data will be collected from remote
PCs. Please note that some data is collected through the Windows Management Instrumentation (WMI), so this
service should be enabled on remote PCs.

Collection of the inventory information is activated by the Enumerate LAN button located on the management toolbar.
This button launches the network enumeration to detect PCs in all available domains and workgroups within the local
network. Inventory information is extracted from all remote PCs and stored in the local database. If you would like to
reduce the range of scanned PCs, you can choose other options, like a scan by IP range, available from the
Enumerate LAN  pop-up menu.

After a scan the Machine Tree displays detected PCs grouped by domains and workgroups. You can browse the tree
to see the inventory information for the selected tree node. Thus, you can see asset information for workgroup/domain

or PC or components of particular PC, etc.
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Pic 2. Enumerate LAN options Pic 3. Inventory scan results

When you make the first scan, the Machine Tree is filled by the collected data. Next time, when you need to make an
inventory, you can choose to collect information from the new PCs available in the network, or to update information on
existing PCs in the tree. In this case you need to use Fetch New or Update buttons on the management toolbar. If you
make Enumerate LAN , then the network scan and the data collection procedure will be repeated again and your
current data will be replaced by the new one.

Browse, Filter and Analyze Inventory Information

When collection of the inventory information is finished, you can browse it by selecting required nodes in the Machines
Tree. By this way you can get the inventory information for each particular PC or the general overview for particular
asset across the network. But if you have hundreds or thousands PCs in the network, it's hard to find required
information.

Network Inventory can help you to easily manage and narrow information by applying filters. For example, let's detect
problematic PCs, which have a lack of memory. In order to find them, select the domain or workgroup under the
Networking node in the tree. Summary information about PCs in this domain or workgroup is displayed on the right
side. This information includes Physical Mem field, so we can apply filter by this field to display only problematic PCs.
Click on the down button on the field's caption and in appeared menu select (Custom. ..) item. On the Custom
AutoFilter dialog select is less than option and enter 1024 value to display only those PCs, which have less than 1GB

of memory. Press OK button to apply the filter.
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Pic 4. Custom AutoFilter dialog Pic 5. Scan results with applied filt er

After applying the filter the displayed data will be updated to show only those PCs that fulfill the filter condition. Pic 5
Note that you can apply multiple filters and once, for example to detect PCs that have Windows Vista and a low
memory.

Prepare Inventory Report

Collecting information from remote computers is only a part of the inventory task. Usually, the asset information should
be composed into printable reports for the management or further reference by IT team. Network Inventory provides
few easy ways to prepare reports. First, you can save information displayed on screen in various formats if you click on
the Export Displayed  button. Second, you can generate a set of detailed predefined reports. Third, you can your own
custom reports.

All reports are customizable. It means that you can change the title page and put your name and company logo to it.
To customize report select File > Preferences... item from the main menu and go to the Report tab. Change report
Title , Description and set Author and Company Logo . L2 Press OK button to apply settings.
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Pic 6. Report customization options Pic 7. Field Output Selection dialog
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Pic 8. Report title page Pic 9. PC Summary report

Let's create inventory report in PDF format for all PC. To generate the report select Reports > Machine Data > Export
to File > All item from the main menu. On the appeared Field Output Selection  dialog you can choose what data
should be included into the report. Make you selection, press OK and proceed to the Save As dialog where you
need to enter the file name and choose Adobe Acrobat Document as output format. Press Save button to generate the
report and open it in the Acrobat Reader. You can see logo and customized captions on the title page. Other
pages contain information selected for inclusion into the report.

Reconcile Software Licenses

A list of installed applications for each PC is available under the Installed Apps node in the Machines Tree . It
represents the same data as displayed by the Add/Remove Programs in the Control Panel . But if you have a lot of
computers in the network, it's very hard to get the general vision what software is used in the organization, because
the information represented per PC.

The summary information about software used within organization is available in the Enterprise Edition on the Machine
Tree under the Management Tools > Installed Applications . The Count Applicaton node opens the dialog that
represents all software items found in the network together with the number of used copies. It helps you to
have the summarized information about all software assets. But such representation has two disadvantages. First, it
includes a freeware that should be often skipped from the software assets evaluation. Second, it groups software by
the full name coincidence, so same applications with different version numbers can be represented few times in the
list.

To filter out applications from the summary view, the Installed Application Exclude List dialog can be used. It is
activated by the Maintain Exclud e List node. In this dialog you can define a application name mask to remove all
occurrences according with mask from the applications list. The similar functionality is available for application
entries grouping. Using the Maintain Groups List node you can activate dialog where set the mask and group name.
All entries compliant to mask will be replaced by the defined group name.


http://emco.is/img/products/network-inventory/getting-started/large/08.gif
http://emco.is/img/products/network-inventory/getting-started/large/09.gif
http://emco.is/products/network-inventory/getting-started.php
http://emco.is/products/network-inventory/getting-started.php
http://emco.is/products/network-inventory/getting-started.php
http://emco.is/products/network-inventory/getting-started.php
http://emco.is/products/network-inventory/getting-started.php
http://emco.is/products/network-inventory/getting-started.php

L BT b e

e e Bt B vy duldar G Ciousiosy * imsrmersan Tosiy t Comiens ) iex fodent it

ERIx el ([T s——
b3 — i S i s Pl o il it Yot
- el e o
= @k P e
'II‘F'F‘:'H‘_ A | T e | e
J=——rn ibu- n hga e
o 5 e i d -
] S o i e F akie A
et - 7 i B
" ettt T - [ T T P —
O g s e Pk e s Pl
= Z [ = [y T e —"—
o Ve, Py - 11 Bt s e Fusmaraal
= - b snns [ | mpeas
Bt b Cpmrs . § s Bty Lo P’
:';:"" = 1 i ol Pl
1“_". "—H.h e : o —" n-.....l.—‘
oo “mn-.- A= (T —
g vendna 0 i Pty et
= 1 1 ) Bty sl Py’
e | e
([ e — ] e
iu--.-u_l,.- = [T [ -
s G L = 2R B f enrd 18 el b
L s s o Fn C 1 i 1 i e
e - IS L )
[ —— 0 ¥ ot Y Pttt 11
4 W Do Ll 0 [T
- : - 7 WA ey gt i
b e e e = T i

I s N

Pic 10. Installed Applications Count dialog
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Pic 11. Installed Application Exclude List dialog
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Pic 12. Installed Application Groups List dialog

Finally, when freeware is filtered out and all groups are defined, you can select the Reconcile Licenses node to open

Pic 13. Reconcile Licenses dialog

correspondent dialog.  Pic 13 Jyof dialog can help you to review all software assets. You can see a number of used

copies for each application and can enter the number of licenses that your organization owns to get the number of
unused or required licenses. Such approach can easily show a licensing problem and simplify decision making for

software purchases.

Detect Licensing or Policies Violations on Remote PCs

Network Inventory has an ability to make a custom search on remote computers. You can define specific conditions to
search resources on the file system and registry. This feature is useful in various cases, for example, to detect remote
PCs with specific resources, settings or viruses, etc. It can help also to detect licensing or company policies violations.

For example, let's detect PCs that have MP3 files on hard drives.

Remote search options are available in the Enterprise Edition under the Scan Operations
To make a files scan select File Syst em Scan node and press Add button to configure a new scan task. On the

node in the Machine Tree .

appeared Add Scan Task dialog enter scan task name and description. CZTE I New scan task will appear in the tree
and you can select it to configure conditions. Click on the Add button on the toolbar and on the Add Scan Criteria

dialog enter file mask *mp3 and select %All Drives%
Press OK button to finish.

as a search criteria to look for MP3 files on all available drives.
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Pic 14. Add Scan Task dialog

Pic 16. Add Machines to Queue dialog

Next, we need to configure the search scope, so click on the Include Machine
toolbar. On the appeared Add Machines to Queue

Pic 15. Add Scan Criteria dialog

Pic 17. View Scan Results dialog

where search should be performed and press OK button to fill the Machine Queue .

in the search results.

button located on the Machine Queue

dialog you can choose domains/workgroups or individual PCs
When search conditions
and Machine Queue are configured, you can launch the search by pressing Run Now button on the toolbar. After scan
completion you can see search results below. To get a detailed report about resources found, you can click on the row
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